Excel: uso delle funzioni SE e CONTA.SE

In questo articolo impareremo l’utilizzo delle funzioni Excel SE e CONTA.SE per la risoluzione di un caso concreto.

Un caso concreto da risolvere

L’ufficio Ministeriale ha necessità di gestire i contributi richiesti per l’incentivo all’acquisto delle auto elettriche da parte delle imprese.

Le regola dettate dal Bando sono:

  1. finanziare solo le imprese con un reddito minore di 100.000,00 Euro
  2. concedere all’impresa con reddito minore di 100000,00 Euro un importo massimo del 38% della fattura inviata per un massimo di 15000,00 Euro.

L’impiegato del Ministero tramite Excel desidera:

  1. contare il numero delle imprese che hanno presentato domanda con un reddito minore di 100.000,00 Euro;
  2. calcolare la percentuale del 38% sulla fattura e concedere il contributo per un importo massimo di 15000,00 EURO solo se il fatturato è maggiore di 100.000,00 Euro;
  3. altra accortezza è quella di assegnare un contributo per un massimo di 15000,00 Euro;
  4. per ultimo sommare gli importi concessi alle imprese  con reddito minore di 100.000,00 Euro;

Di seguito la tabella completa con le domande ricevute ed i calcoli effettuati tramite le formule SE e CONTA.SE

Spiegazione delle formule inserire in tabella

I dati caricati dall’impiegato sono quelli relativi alle colonne DENOMINAZIONE e Fatturato in tutte le altre colonne il contenuto e calcolato dalle formule.

La  colonna flag. In questa colonna comparirà S se l’importo del fatturato sarà minore di 100000,00 e N se sarà maggiore o uguale.

Utilizzo della funzione SE

La formula per effettuare questo controllo sarà =SE(C4<100000;”S”;”N”). In parole povere ci stiamo chiedendo SE il contenuto della cella C4 (Fatturato) è minore di 100000,00 sarà uguale a S altrimenti N.

Nel nostro caso specifico la cella è uguale a S (ammesso) perché il fatturato è uguale a 84219,00.

Utilizzo della funzione CONTA.SE

Per contare le imprese che hanno ottenuto il contributo basterà contare tutte le celle della colonna flag con all’interno S.

Qui impareremo l’utilizzo della funzione CONTA.SE

Per contare le imprese ammesse utilizziamo la formula CONTA.SE in questo modo: =CONTA.SE(A4:A24;”S”). Il risultato nel nostro caso specifico sarà uguale a 14.

Ora passiamo alla soluzione di altre problematiche.

Nella colonna 38% della fattura viene calcolato il 38% della colonna Importo Fattura con la seguente formula =+D4*38%. Prendendo come riferimento la prima riga della tabella, il contenuto della cella sarà in E4

Ora la parte più interessante è quella utilizzata per calcolare il Contributo ammesso. Qui utilizzeremo un innesto di SE.

Ecco la formula =SE(C4<100000;SE(E4>15000;15000;E4);0)

Cosa significa?

Se il fatturato è minore di 100000,00 controllo se il 38% della fattura(E4) è maggiore di 15000,00 e se fosse vera questa condizione concediamo il contributo.

Ma quanto sarà l’importo del contributo?

Per questo abbiamo necessità di effettuare un altro controllo (innesto della formula SE) perchè il Bando recitava: per un massimo di 15000,00 Euro.

Se il 38% della fattura (cella E4) è maggiore di 15000,00 Euro verrà concesso 15000,00 in caso contrario sarà il contenuto della colonna 38% della fattura e quindi il contenuto della cella E4.

Nel nostro esempio nella prima riga si noterà che il contributo concesso è pari a 15000,00 Euro perché il 38% della fattura è maggiore di 15000,00 (16.362,80 Euro).

L’ultimo utilizzo della formula SE viene fatta nella colonna Progressivo ammesso dove vengono sommati progressivamente solo i contributi Ammessi. La formula per ottenere questo conteggio sarà =SE(A5=”S”;+G4+F5;G4+0)

In pratica SE il flag è uguale a S si somma il Contributo ammesso al parziale precedente nella colonna Progressivo ammesso altrimenti sommo zero.

La Tabella Excel con i dati

Tabella excel esempio SE e CONTA.SE

Download del file Excel con l’esempio svolto

Download file Excel con tutte le formule utilizzate.